ORF
过滤器
ORF的功能为将本地配置的BGP(边界网关协议)前缀过滤器“推送”给远程对等体,以便远程对等体将收到的过滤器应用为自己的又一出站过滤器。
出站路由过滤
简介
ORF:Outbound Route Filtering
好处是降低了所要通告的前缀数量,从而减少BGP路由更新数量;减轻本地路由器工作量。详细信息可以看RFC5291文档。
例子
下面是一个例子:
拓扑:
R5------------R7
R5用2个回环口模拟子网(5.5.5.5/32和 55.55.55.55/32)
R7用2个回环口模拟子网(7.7.7.7/32和77.77.77.77/32)
R5和R7之间是192.168.25.x/24
R5的AS号为5
R7的AS号为7
实验目的:
要过滤r7的77.77.77.77/32的条,可以在r7的out方向做,也可以在r5的in方向做.显然在r7的out方向上做效率高,可以节省两端处理报文的cpu资源和链路负载(这里只有一条,但实际可是几百、千条)。
如果r7是其它isp(互联网服务提供商)的路由器,对r5来讲,无权配置r7时,这里提供了一种可选方案:
在r5上配置
r5(config)#ip prefix-list abc seq 5 permit 7.7.7.7/32
r5(config)#ip prefix-list abc seq 10 permit 88.88.88.0/24
将prefix-list abc 用在neighbor 192.168.25.7 prefix-list abc in上(neighbor 192.168.25.7 prefix-list abc in),
r5(config-router)#nei 192.168.25.7 capability orf prefix-list both [启用orf能力,此命令输入后在show run中不可见,不知道为何?]
r7(config-router)#nei 192.168.25.5 capability orf prefix-list both [r7也启用orf能力]
r5#clear ip bgp 192.168.25.7 in prefix-filter [作用:向邻居r7推出前缀列表,以用于r7的out方向]
结果:查看r7发给邻居192.168.25.5(r5)的条目,是没有77.77.77.77/32的,说明在出r7时就已经被前缀列表滤掉了.但这个列表却是在r5上配置的.
r7#sh ip bgp nei 192.168.25.5 advertised-routes
BGP table version is 14, local router ID is 7.7.7.7
Status codes: s suppressed, d damped, h history, * valid, >best, i - internal,
r RIB-failure, S Stale
Origin codes: i -IGP, e -EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>7.7.7.7/32 0.0.0.0 0 32768 i
*>88.88.88.0/24 0.0.0.0 0 32768 i
hostname r5
!
logging queue-limit 100
!
ip subnet-zero
no ip domain lookup
!
!
!
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface Loopback1
ip address 55.55.55.55 255.255.255.255
!
interface Ethernet0
ip address 192.168.25.5 255.255.255.0
!
interface Serial0
no ip address
!
interface Serial1
no ip address
!
router bgp 5
no synchronization
bgp router-id 5.5.5.5
bgp log-neighbor-changes
network 5.5.5.5 mask 255.255.255.255
network 55.55.55.55 mask 255.255.255.255
neighbor 192.168.25.7 remote-as 7
neighbor 192.168.25.7 prefix-list abc in
no auto-summary
!
no ip http server
ip classless
!
!
!
ip prefix-list abc seq 5 permit 7.7.7.7/32
ip prefix-list abc seq 10 permit 88.88.88.0/24
!
!
!
hostname r7
!
logging queue-limit 100
!
ip subnet-zero
!
!
!
!
interface Loopback0
ip address 7.7.7.7 255.255.255.255
!
interface Loopback1
ip address 77.77.77.77 255.255.255.255
!
interface Loopback2
ip address 88.88.88.88 255.255.255.0
!
interface Ethernet0
ip address 192.168.25.7 255.255.255.0
!
interface Serial0
no ip address
shutdown
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router bgp 7
no synchronization
bgp router-id 7.7.7.7
bgp log-neighbor-changes
network 7.7.7.7 mask 255.255.255.255
network 77.77.77.77 mask 255.255.255.255
network 88.88.88.0 mask 255.255.255.0
neighbor 192.168.25.5 remote-as 5
no auto-summary
图片格式
奥林巴斯Olympus)数码相机的raw(非压缩图片)的后缀为orf。
阅读框
开放阅读框(或开放读码框架,open reading frame,ORF)是DNA上的一段碱基序列,由于拥有特殊的起始密码子和直到可以从该段碱基序列产生合适大小蛋白才出现的终止密码子,该段碱基序列编码一个蛋白。当一个新基因被识别,其DNA序列被解读,人们仍旧无法搞清相应的蛋白氨基酸序列是什么。这是因为在没有其它信息的前提下,DNA序列可以按六种框架阅读和翻译(每条链三种,对应三种不同的起始密码子)。ORF识别包括检测这六个阅读框架并决定哪一个包含以起始密码子和终止密码子为界限的DNA序列而其内部不包含起始密码子或终止密码子,符合这些条件的序列有可能对应一个真正的单一的基因产物。ORF的识别是证明一个新的DNA序列为特定的蛋白质编码基因的部分或全部的先决条件。
An open reading frame (ORF) is a portion of a gene’s sequence that contains a sequence of bases, uninterrupted by stop sequences,that could potentially encode a protein. When a new gene is identified and its DNA sequence deciphered,it is still unclear what its corresponding protein sequence is. This is because, in the absence of any other knowledge,the DNA sequence can be translated or read in six possible reading frames (three for each strand,corresponding to three different start positions for the first codon). ORF identification involves scanning each of the six reading frames and determining which one(s) contains a stretch of DNA sequence bounded by a start and stop codon,yet containing no start or stop codons within it;a sequence meeting these conditions could correspond to the actual single product of the gene. The identification of an ORF provides the first evidence that a new sequence of DNA is part or all of a gene encoding for a particular protein.
过滤器
简介
ORF是由Vamsoft公司发行的基于服务器端的垃圾邮件过滤器,可作为插件与Exchange 2000/2003服务器快速简单集成,也可单独作为反垃圾网关与其它任何邮件系统配合使用。在同类产品中,ORF以极低价格优势、高准确识别率和极低出错率,为广大中小型企业提供优质的反垃圾邮件服务。
核心技术
利用的ORF的几个特别技术,即可简单、快速、准确地过滤垃圾邮件,配置一旦完成,无须再手工处理。
Greylisting
不管群发垃圾邮件内容和邮件头部如何变化,Greylisting都能够阻掉绝决大部分群发垃圾邮件且无任何误判
SURBL
不管垃圾邮件内容如何多变,只要邮件内容的网页链接被加入到反垃圾邮件组织SURBL。ORG,则都无法逃过ORF的过滤
SPF
任何冒用他人域名(已使用SPF的)发送的垃圾邮件都无法躲过ORF的过滤
SMTP会话其间过滤
在SMTP会话其间就对邮件进行过滤,即使邮件被误判为垃圾,ORF会在SMTP会话其间发送拒绝信息给发送方服务器而结束SMTP会话,NDR退信由发送方负责发送,从而避免任何邮件的丢失。
自动白名单
ORF能够自动监控任何外发邮件并把外发邮件的收件人加入到白名单里,以后对方发来的邮件都能够被ORF当作合法邮件而接收,从而把垃圾邮件误判率减少到最低。
其它功能
AD集成、DNS黑名单、附件过滤、关键词过滤、IP黑白名单、收/发件人黑白名单、反向DNS检测、第三方插件等,可根据实际需要配合使用,把垃圾邮件减少到最低。
参考资料
最新修订时间:2023-10-20 20:13
目录
概述
出站路由过滤
参考资料